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Introduction 

 
What is PDF? Portable Document Format (PDF) was developed by Adobe for the 

distribution of electronic documents in a format that preserves the 
exact layout, font attributes, and formatting of the document from 
which it was created, ensuring that the electronic version of a 
document retains the exact look of the source material. 

 
Tagged PDF Accessible PDF documents use tags to indicate the structural elements 

of the document's content, such as which page elements are headings, 
graphics, paragraphs, tables and so on, and how these elements relate 
to each other. 

 
A properly tagged PDF will also integrate with a range of assistive 
technologies including Braille devices and screen readers. 

 
Design with 
Accessibility in 
Mind 

Much of the work in creating an accessible PDF document happens in 
the creation of the document itself, not in the conversion to PDF. The 
key is to design the document in its source application, such as 
Microsoft Word, using techniques designed to enhance the 
accessibility of the final PDF document. 
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Word Checklist 
All or most of the responses to these checklist items should be "Yes" or "N/A" (not 
applicable) prior to converting a document to PDF. If a "No" response is used, the item 
will need to be repaired in the PDF document. 
 Yes/No

1. The latest version of Microsoft Word was used.  
2. System fonts were used.  
3. Hyphenation was used properly (i.e., no hard hyphens).  
4. Color is not the sole means of conveying information.  
5. Contrast is sufficient.  
6. Text and images are visually separated (i.e., elements have not been 

overlapped, such as text over a background color or image). 
 

7. Watermarks have not been used.  
8. Foreground and background color combinations provide sufficient contrast 

when viewed using various high-contrast color combinations.  
 

9. Black or dark colors have been used for body text.  
10. Reverse text has not been used (i.e., light text on a dark background).  
11. Complex images have been grouped.  
12. Images which convey information have meaningful alternate text applied.  
13. Images which do not convey information have a carriage return as alternate 

text. 
 

14. Images are "in line" with text.  
15. Text boxes have not been used.  
16. Animations have not been used, or if they have, there is a way to disable 

them. 
 

17. A text description has been provided which describes embedded elements.  
18. Styles, formatting, and structural elements have been used effectively to 

provide structure to the document. 
 

19. Accurate and effective navigational features, such as hyperlinks, tables of 
contents, and indexes, have been included as appropriate, using Microsoft 
Word's built-in features. 

 

20. Tables have been created properly and simply.  
21. A text description has been provided within the content which describes 

complex tables, their structure, and contents. 
 

22. Columns have been created properly.  
23. Headers and footers have been created properly.  
24. Document properties have been set (at a minimum, title and author).  
25. The document has been spell-checked.  
26. The document has been proofread.  
27. All links have been verified for accuracy.  
28. A final Save As was performed prior to PDF conversion.  
29. The file was converted using the accessible.joboptions file.  
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Acrobat Checklist 
All or most of the responses to these checklist items should be "Yes" or "N/A" (not 
applicable). If a "No" response is used, the item should be addressed in an alternate 
fashion which renders the document accessible. 

 Yes/No 
1. Bookmarks link to the appropriate destination.  
2. Bookmarks are nested properly.  
3. Bookmarks are labeled properly.  
4. All comments have been deleted.  
5. Document language has been defined.  
6. Foreign words or phrases have language definitions.  
7. Tab order is logical.  
8. There are no character mapping problems; or a workaround, such as 

alt text or artifacts, has been applied. 
 

9. All elements are contained within the tag tree.  
10. Read order is logical.  
11. Reflow is logical.  
12. Alternate text is used appropriately.  
13. Elements which should be ignored by a screen reader have been 

marked as artifacts. 
 

14. Empty tags have been deleted.  
15. Tables are marked up properly, using TH for column and row 

headings; or a workaround, such as descriptive text, has been 
applied. 

 

16. Hyperlinks are active.  
17. Hyperlinks link to the appropriate destination.  
18. Hyperlink text is descriptive of its destination.  
19. The initial view has been set to open the Bookmarks tab.  
20. The user's magnification settings have not been overridden, unless 

there is a strong reason to do so. 
 

21. All text is readable in each of Acrobat's high-contrast color 
combinations. 

 

22. Abbreviations have alternate text applied, if necessary.  
23. Information conveyed solely with color is available in another way, 

such as alternate text. 
 

24. Adequate structure has been applied to the document.  
25. The Accessibility Full Check returns no warnings.  
26. A screen reader has been used to validate that the document makes 

sense when read aloud. 
 

27. The file has been optimized using the accessible.optimize file.  
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Step 1: 
Creating an Accessible Document in Microsoft Word 

Use the Latest Version of Microsoft Word 

 
Why It's 
Important 

Each newer release of Word has greater accessibility features and 
functionality, and will convert to a more accessible PDF. 

 
Techniques Use the latest release of Microsoft Word, rather than an older 

version, to create/modify Word documents. 
Open old Word documents in the latest release of Microsoft Word 
and resave them prior to beginning the accessible workflow.  
Note: Save the document at the end of each step and append a 
different version number to the end of the filename. Word will 
sometimes crash which can cause the document to become corrupted 
or recent edits to be lost. 
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Use System Fonts 

 
Why It's 
Important 

System fonts are those fonts installed by default with the Windows 
operating system. By using only these fonts, documents allow for the 
reliable extraction of textual content for assistive technology. 

 
Techniques Use easy-to-read system fonts when creating/modifying documents. 

Note: This is no guarantee that a character is going to be accessible to 
a screen reader. There are many characters within a system font that 
cannot be read by assistive technology. Ultimately, the final test is to 
determine if the character is read properly by a screen reader. If it 
cannot be read, consider an alternate method of achieving the same 
effect, such as using a graphic with alternative text, instead. 
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Do Not Use Hyphenation 

 
Why It's 
Important 

A word that has been hyphenated using the automatic hyphenation 
feature will often be mispronounced by a screen reader. For example, 
"photo-graphy" with a hyphen will likely be mispronounced as "fO-tə-
graf-E," (photo graph E) rather than correctly pronounced as "fə-tä-
grə-fE" (fa tog ruhh fee). This could be confusing for users of screen 
readers. 
Also, if the document is repurposed to another format, the hard 
hyphen will travel along, creating a word like "photo-graphy" which is 
not a word that should be separated by a hyphen. 

 
Techniques Do not insert hard hyphens (using the dash/hyphen key) and line 

breaks to force end-of-line hyphenation, and delete them if they've 
been used. 
If hyphenation is desired, allow words to be hyphenated by the 
application. 
To turn off the automatic hyphenation feature, be sure Microsoft 
Word's hyphenation preferences is not set to automatically hyphenate 
the document. 

1. Select Tools > Language > Hyphenation…  
The Hyphenation dialog box opens. 

 
2. Uncheck the check box for Automatically hyphenate 

document if it is not already checked. 

 
3. Set the other hyphenation preferences as appropriate. 
4. Select OK. 
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Use Color Wisely 

 
Why It's 
Important 

Using color to emphasize or call attention to certain elements may 
help make documents easier to read for many people. However, when 
color is used as the only way to convey information, meaning can be 
lost to those with visual disabilities. 
For example, if completed items in a table are indicated by a green X 
and incomplete items shown as a red X, they may look identical to 
someone who is color blind, and they will sound the same to someone 
using a screen reader. 
Example: 

 Task Completion 
The following table shows those tasks which have been completed (X) 
and those which have not (X):

Task Due Date Completed 
Task 1 January 3, 2006 X
Task 2 February 9, 2006 X
Task 3 March 4, 2006 X

 
Techniques Only use color as an enhancement, not as the sole means of 

conveying information. 
Provide an alternative to color for distinguishing the items. For 
example, use a green "Y" and a red "N" instead of different-colored 
checkmarks.  
Example: 

 Task Completion 
The following table shows those tasks which have been completed (Y) 
and those which have not (N):

Task Due Date Completed 
Task 1 January 3, 2006  Y
Task 2 February 9, 2006  N
Task 3 March 4, 2006  Y

 
Techniques If images are used, provide appropriate alternative text so they can 

be read by a screen reader. 
Example: 
 Task Completion 
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The following table shows those tasks which have been completed 
( ) and those which have not ( ):

Task Due Date Completed 
Task 1 January 3, 2006  
Task 2 February 9, 2006  
Task 3 March 4, 2006  
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Ensure Contrast is Sufficient 

 
Why It's 
Important 

Good contrast improves accessibility by making elements easier to 
read and distinguish. 
Some users may use various contrast color schemes to increase the 
legibility of a document by heightening screen contrast with 
alternative color combinations. Text over background color or images 
may be impossible to read after a high-contrast color scheme is 
applied. 
Reverse text (i.e., light text on a dark background:  Reverse Text  )  is 
discouraged because results can be unexpected. 

 
Techniques Visually separate text and images: 

• do not overlap elements, such as text over a background color, 
pattern, or image, and 

• avoid the use of watermarks.  
Ensure that foreground and background color combinations provide 
sufficient contrast when viewed by someone having a color 
impairment or when viewed on a black and white screen.  
Use black or dark colors for text. 
Do not use reverse text (i.e., light text on a dark background). 
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Add Alternate Text to Non-Text Elements 

 
Why It's 
Important 

The alternate text for an image provides replacement information that 
can be read by assistive technology for those users unable to see the 
image, so they can make sense of the document. 
Alternate text should succinctly convey in words the same information 
that is communicated by the non-text element. It should represent the 
meaning, function, or purpose of the image, not its appearance.  
A non-text element is anything present on the page which is not 
represented by a font character that can be interpreted reliably by 
assistive technology. 
An artifact is any content that is unimportant or possibly even 
distracting to the user accessing the document. They are non-
informational images and should be marked as artifacts so that they 
are not vocalized by the screen reader. 

 
Techniques Ensure all non-text elements have alternative text if they convey 

information important to understanding the content or context of 
the document. 
If an image conveys no information (i.e., it is decorative or 
redundant to the text), enter a carriage return using the Enter key as 
the alternate text. 
To provide a text alternative for an image: 

1. Select Format > Picture.  
The Format Picture dialog opens. 

2. Select the Web Tab. 
3. Add the appropriate alternative text in the space provided. 
4. Select OK. 
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Create Columns Properly 

 
Why It's 
Important 

Columns should be read line by line down the left column, then line 
by line down the right column, rather than reading each line straight 
across the two columns.  
Using the Columns toolbar button to create multiple columns provides 
structural information about how to structure the tags that represent 
lines of text in the columns so that they are interpreted correctly by 
assistive technology.  

 
Techniques Create columns properly by using Format > Columns or the Insert 

Columns icon.  
Do not use tabs, spaces, text boxes, borderless tables, or other "tricks" 
to create the look of columns in a document. 
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Create Tables Properly and Simply 

 
Why It's 
Important 

A table's structure needs to be simple so that it makes sense when read 
by a screen reader, left to right, row by row. The more complex a table 
becomes, the more difficult it is to understand when read by assistive 
technology. 

 
Techniques Use the "Insert Table" or "Draw Table" feature to create tables. 

Use tables only for displaying structured data. 
Simplify tables as much as possible.  

• Avoid nesting tables (putting one table inside another). 
• Avoid merging/splitting cells. Use a distinctive cell for each 

data entry. 
• Do not use tabs, spaces, dashes, dots, or other "tricks" to create 

the look of a table in a document. 
If a complex table is used, provide a description of the table 
structure and its contents within the content of the document.  
If this is not possible, some tagging will be necessary in the PDF 
document (see Adding & Improving Accessibility Features in Acrobat 
later in this document). 
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Create Headers and Footers Properly 

 
Why It's 
Important 

Inserting headers and footers properly provides structural information 
about how to structure the tags that represent headers and footers. In 
this case, PDFMaker will know to convert them to artifacts so that 
they will be ignored by a screen reader. 

 
Techniques Create headers and footers properly. 

Choose View > Header and Footer from the menu. The Header and 
Footer toolbar opens. (Note: This toolbar is only available while the 
cursor is within a header or footer.) 
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Group Complex Images 

  
Why It's 
Important 

By grouping a composite image into a single image, alternate text can 
then be applied to this single image.  
This grouping "passes through" to the PDF as a single figure element, 
with alternate text, rather than as several separate figure elements, 
some of them possibly missing alternate text. 

 
Techniques Use the Group command to group complex images into a single 

image and then add alternate text to the single image. 
1. Select the images which need to be grouped. 

 
2. Draw > Group from the Drawing toolbar. 

 
3. Apply the appropriate alternative text to this single grouped 

image. 
a. Select Format > Picture. 
b. The Format Picture dialog opens. 
c. Select the Web tab. 
d. Add the appropriate alternative text in the space 
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provided. 
e. Select OK. 
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Ensure Images are "In Line" 

 
Why It's 
Important 

If an image "floats" on a page, it may visually appear where intended; 
however, it is outside the structure of the document and will not be 
positioned reliably within the tag tree after PDF conversion. 

 
Techniques Ensure images are inserted "In line with text", rather than as a 

floating image (Square, Tight, Behind text, or In front of text). 
1. Select an image. 
2. Select Format > Picture from the menubar. 
3. The Format Picture dialog opens. 
4. Select the Layout tab. 
5. Select "In line with text" as the Wrapping style. 
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Do Not Use Text Boxes 

 
Why It's 
Important 

Text boxes are containers for text that can be positioned on a page and 
sized. They are inserted using Insert > Text Box, or by selecting the 
Text Box icon on the Drawing toolbar. 
Text boxes are extremely unreliable in transferring information to a 
PDF file. Reading order and alternate text are not preserved during the 
conversion process.  
The two examples which follow are both text boxes. The first has a 
border and the second does not. 

  
When selected, they look like this: 

 

 

 
Techniques Do not use text boxes.  

To find and delete text boxes within a document:
1. Switch to print layout view (View > Print Layout). 

 
2. Select Edit > Find. 
3. Select the Find tab. 
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4. Select the Highlight all items found in: checkbox. 
5. Select Text Boxes in Main Document from the dropdown 

menu. 
6. Select the More button to open the lower half of the dialog 

box. 

 
7. Select the Use wildcards checkbox under Search Options.  
8. Enter an asterisk (*) in the Find what: text field. 
9. Select Find All. 

Everything within all text boxes within the document will be 
highlighted and the Find tab will report the number of items 
found (e.g. Microsoft Word found 3 items matching this 
criteria.). Scroll through the document to see the highlighted 
text boxes. 

10. Select Close. 
The highlighted text boxes will look like this: 

 
11. Select each text box and delete it after copy/pasting its content 

as needed. (To select a text box, move the pointer over the 
border of the text box until the pointer becomes a four-headed 
arrow, and then select the border.) 

 
The Find feature may need to be used iteratively to find each text box, 
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until all are gone. 
If a document has no more text boxes, the option will not appear in the 
Highlight all items found in: dropdown menu. 
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Use Styles, Formatting, and Structural Elements 

 
Why It's 
Important 

A style is a set of formatting characteristics applied to text, tables, and 
lists in a document to quickly change their appearance. Styles also 
impose a relational structure (hierarchy) on a document by assigning 
outline levels to paragraphs. 
Structural elements provide information about the organization and 
hierarchy of a document's content. This is an important way of 
conveying meaning and significance. Screen readers are able to read 
specific structural elements at the discretion of the user, which allows 
a user to "skim" through a document, reading only the headings. 
Navigational aids, such as tables of contents and indexes can be 
automatically generated from structural elements, such as headings 
and styles. 
Structural elements, such as titles, headings, subheadings, lists, 
columns, tables, and hyperlinks, are carried over to the PDF during 
conversion. They retain many of their characteristics and are the basis 
for creating an accurate tag tree structure in the PDF document. 
The tag tree, in turn, controls the read order and reflow of information 
on a page, and how the document is interpreted by assistive 
technology, such as screen readers. 

 
Techniques Use Microsoft Word's "Styles and Formatting" features to provide 

structure to documents. 
Create titles, headings, subheadings, paragraphs, characters, 
bulleted/numbered lists, headers/footers, tables, columns, tables of 
contents, indexes, bookmarks, and hyperlinks, using Microsoft Word's 
built-in features.  

1. To open the Styles and Formatting panel, select Format > 
Styles and Formatting, or click the Styles and Formatting 
icon on the formatting toolbar. 

  
2. The Styles and Formatting pane opens. 
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3. Use the automatic list feature to create bulleted and numbered 

lists. 
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Create Navigational Aids 

 
Why It's 
Important 

Navigational aids, such as indexes, links, and tables of contents help 
assistive technology users to more easily navigate to specific areas 
within a document without having to listen to it in its entirety. 
Since assistive technology has the ability to skip through a document 
by links, without reading the surrounding content (i.e., out of context), 
the text of the link should tell the user about what they are going to 
find if they click the link.  
If links are active, they will "pass through" as active links to the PDF 
document. 
Additionally, bookmarks in the PDF can be automatically generated 
during conversion to PDF by using headings and styles (that the 
author selects) to create a hierarchical navigational system within the 
PDF. 

 
Techniques Include accurate and effective navigational features, such as 

hyperlinks, tables of contents, and indexes, as appropriate, using 
Microsoft Word's built-in features. 
Ensure that all hyperlinks are descriptive of their destination: Do not 
use "Click here" or just the URL to describe a hyperlink. Use 
descriptive text as the link, such as: 
Visit the online Usability Center on the SSA intranet. 
Ensure all navigational aids, such as links, are active and accurate. 

 
Notes "Screen tips" applied to hyperlinks do not pass through to the PDF. 

Hyperlinks should appear on a single line. Links which break across 
two or more lines can cause problems with the way the link is read by 
a screen reader. 
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Keep It Simple 

 
Why It's 
Important 

Complex or inconsistent visual displays or word choices can make 
documents difficult to understand—especially to someone with a 
disability. 

 
Techniques Keep page layout simple. Do not create complex layouts. 

Avoid animated text, where the text or images around the text move. 
Avoid the use of animated images and multimedia in documents. 
If embedded elements are used, provide a text description of the 
element within the context of the document. 
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Set Document Properties 

 
Why It's 
Important 

Document properties are information about the document (metadata) 
that is set in the document properties dialog box within Microsoft 
Word. This information is then "passed through" to the PDF during 
conversion. 
Most search engines use the title of a document to describe the 
document in their search results list. If a PDF file does not have a title, 
the file name appears in the results list instead. A file's title is not 
necessarily the same as its filename. 
A natural language document title, such as "Application for Benefits," 
when read aloud by a screen reader, is much more comprehensible 
than a shortened form such as "BeneApp," or no title at all. Without a 
title, a screen reader will likely read the filename aloud. This could be 
as uninformative as "appl_ben_version4.pdf". 
Setting other document properties, such as subject, category, and 
keywords, is also useful for returning high-quality search results. 
In addition, setting the author of the document is extremely helpful in 
tracking down the originator of the document. This may be necessary 
when it is time to update the document, or for dealing with document 
issues, such as security settings, certifications, and signatures. 

 
Techniques Set document properties in Microsoft Word. 

1. Select File > Properties. 
2. The Document Properties dialog box opens. 
3. Select the Summary tab if it is not already selected. 
4. Fill in the appropriate document information, such as title, 

author, and keywords. 
5. Press OK. 
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Proofread 

 
Why It's 
Important 

If a PDF document is created from an inaccurate Microsoft Word 
document, edits will need to be made in both the Word document and 
the PDF document when errors are discovered later in the workflow. 
Otherwise, there is a risk of re-introducing the same errors the next 
time a PDF is generated from the Word document.  
Alternately, once errors have been discovered, the PDF could be 
regenerated, but this would cause any edits to the PDF document to be 
lost. 
Either scenario is time-consuming and confusing and can introduce 
further errors. 

 
Techniques Proofread the document: 

• Ensure that spelling and grammar are correct by using 
Microsoft Word's spelling and grammar checker to check the 
entire document. 

• Proofread the document for errors that the automated spelling 
and grammar checker may not have found and then update the 
document accordingly. 

• Have someone other than the document author proofread the 
document for errors that may have been missed in the earlier 
steps and then update the document accordingly. 

Update all application-generated references, such as table of 
contents and indexes. 
Resave the document. 
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Step 2: 
Converting to an Accessible PDF Document 

From Microsoft Word 

Conversion Settings 

 
Why It's 
Important 

By setting the PDF conversion settings appropriately and using the 
"Convert to Adobe PDF" feature, many accessibility features can be 
included in the PDF output document that would not otherwise be 
included by printing or distilling to PDF. 
When Acrobat Professional 7 is installed, the Adobe PDFMaker 
Macro will become available in Microsoft Office applications. This 
creates a new menu item on the menubar called "Adobe PDF." 

 
Techniques Download the file provided at the following location: 

[http://www.xxx.xxx/accessible.joboption] 
Save the accessible.joboptions file to the Acrobat Distiller Settings 
folder, usually located here: 
C:\Program Files\adobe\Acrobat 7.0\Distillr\Settings 
Note: Use the joboptions file provided until the Conversion Settings 
interface has been mastered. 
Select Adobe PDF > Change Conversion Settings from the 
menubar. 

 
The Adobe PDFMaker dialog opens. 
Unless there is a strong reason to do otherwise, use the settings which 
follow. 

 
Note A Help button is available at the bottom of the dialog box which 

provides context-sensitive help for the currently active tab. 
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Settings Tab In the Adobe PDFMaker dialog, select the Settings tab and use the 

following settings: 
Under PDFMaker Settings, select the accessible.joboptions file from 
the Conversion Settings dropdown list.  
Note: This file should be located in C:\Program Files\adobe\Acrobat 
7.0\Distillr\Settings, unless it was saved elsewhere. If saved 
elsewhere, navigate to and select the appropriate file. 
Under PDFMaker Settings use the following settings: 
• Check: View Adobe PDF result 
• Check: Prompt for Adobe PDF file name 
• Check: Convert Document Information 
Under Application Settings, check the following check boxes: 
• Uncheck: Attach source file to Adobe PDF 
• Check: Add bookmarks to Adobe PDF 
• Check: Add links to Adobe PDF 
• Check: Enable accessible and reflow with Tagged PDF 
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Security Tab In the Adobe PDFMaker dialog, select the Security tab and use the 

following settings: 
• Uncheck: Require a password to open the document 
• Uncheck: Use a password to restrict printing and editing of the 

document and its security settings 

If security settings are used, ensure that "Enable text access for screen 
reader devices for the visually impaired" is checked. 
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Word Tab In the Adobe PDFMaker dialog, select the Word tab and use the 

following settings: 
• Uncheck: Convert displayed comments to notes in PDF 
• Check: Convert cross-references and table of contents to links 
• Check: Convert footnote and endnote links 
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Bookmarks 
Tab 

In the Adobe PDFMaker dialog, select the Bookmarks tab and use 
the following settings:  
• Check: Convert Word Headings to Bookmarks 
• Uncheck: Convert Word Styles to Bookmarks 
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Convert to PDF 

 
Why It's 
Important 

Unlike printing to Adobe PDF, converting to PDF creates tagged 
Adobe PDF files that preserve hyperlinks, styles, bookmarks, and the 
structure of tables present in the source document. 

 
Techniques Perform a final Save As in Word to ensure the file is as small as 

possible. 

 
Use "Convert to PDF" to create PDF documents from Microsoft 
Word, not Print or Distill. 
*If the PDF conversion settings are set properly (see next subject), 
select Adobe PDF > Convert to Adobe PDF from the menubar.

 
*If the PDF conversion settings are not set properly, set them prior to 
using Convert to Adobe PDF (see next subject). 
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Step 3: 
Testing, Repairing, Adding & Improving Accessibility 

Features in Acrobat 

 
Introduction Many of the tools and techniques discussed next are described in 

detail in the Complete Acrobat Help file, which can be accessed by 
pressing the F1 key while Acrobat is open and active.  

 
To learn how to use Acrobat's: Read this section: 
TouchUp Reading Order Tool Editing the Structure of Tagged 

Adobe PDF Documents 
Tags Tab Advanced Tools for Correcting 

Tagging Errors 
Bookmarks Tab Adding Navigability to Adobe PDF 

Documents 
Read Out Loud Feature Customizing Adobe Acrobat for 

Accessibility > Using Read Out 
Loud feature 

 
Note Whenever an issue is encountered within the PDF document, 

instruction have been given to correct the problem within Acrobat. 
However, it is at all times recommended that changes be made in the 
original Word document (if possible) and that it then be converted 
again to PDF. 
Save the PDF file frequently, appending different version numbers to 
the filename. Some Acrobat tools do not include an Undo command, 
and Acrobat will sometimes crash. (An occasional Save As will 
reduce file size.) 
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Manage Bookmarks 

 
Test Review the bookmarks and determine if the bookmarks: 

• link to the appropriate destination, 
• are nested properly, and 
• are labeled correctly. 

 
Note If Word's styles and Adobe PDFMaker's bookmarks feature were used 

properly, the PDF bookmarks should be correct. If they are not, they 
can be corrected in Word, or they can be modified in the Bookmarks 
tab within Acrobat. 
If bookmarks are modified in the Bookmarks tab within Acrobat, 
those same modifications will need to be re-applied every time the 
document is converted from Word. It is recommended that bookmarks 
be corrected in Word. 

 
Techniques To modify bookmarks in Acrobat:  

1. Open the Bookmarks tab by selecting View > Navigation 
Tabs > Bookmarks from the menubar. 

2. Drag bookmarks to where they belong, create/delete 
bookmarks and/or apply formatting using the Options menu. 

(See Adding Navigability to Adobe PDF Documents > Using 
Bookmarks in the Complete Acrobat Help file (F1) for more detailed 
instructions.) 
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Run the Accessibility Full Check 

 
Test Run the Accessibility Full Check to find specific accessibility issues 

which may need attention. 

 
Techniques Check the accessibility of a PDF document using Full Check: 

1. Choose Advanced > Accessibility > Full Check. 

 
2. Select Create Accessibility Report, and then click Browse to 

save a copy to the desired location. 
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3. Specify the pages to be included in the accessibility check. 
4. To view the report as comments in the PDF document, select 

Create Comments In Document. 
5. Select all of the checkboxes for the desired Checking 

Options. 
6. Click Start Checking. 

A dialog opens reporting the problems found in the document. 
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Note the problems found and dismiss the dialog by selecting OK. 
A report opens in the How To window with a list of problems and 
links to specific areas of the document.  
Comments and highlights within the document indicate potential 
problems. 

 
To view and highlight problem individually, open the Comment tab 
and select individual comments within the Comments pane. The 
corresponding element in the document will be highlighted. 

 
After addressing each problem noted by a comment, delete the 
comment (otherwise it will appear as an untagged element the next 
time the Full Check is run). 
To delete a comment, select the comment to be deleted within the 
Comments tab, and then press Delete. 
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Address the Problems Reported by the Accessibility Full 
Check 

 
Warnings After running the Accessibility Full Check, a dialog opens reporting 

the problems found in the document. 
For each problem reported, see the topics noted to eliminate the 
problem. 

 
Accessibility Full Check Message See Topic 

All of the text in this document lacks a 
language specification. 

Define the Language(s) Used

[Number of] elements that are not contained 
within the structure tree. 

Adding Elements to the Tag Tree

[Number of] pages with tab order that may 
be inconsistent with the structure order. 

Set the Tab Order of Pages

[Number of] images and/or Figure elements 
with no alternate text. 

Alternate Text and Artifacts

[Number of] words that contain characters 
with no reliable mapping to Unicode. 

Character Mappings 
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Define the Language(s) Used 

 
Test Ensure the Default Document Language is set to the appropriate 

language. 
Listen to the document using a screen reader. Are all non-English 
words pronounced correctly? If they are not, the language property for 
individual words and phrases may need to be set so that the proper 
pronunciation dictionary is used. (In theory, screen readers should 
change the pronunciation dictionary in order to pronounce words 
according to the language in which they are written. This is not always 
the case with today's screen readers.) 

 
Note The document and text language properties can only be applied within 

Acrobat. If changes are made in the source document, these properties 
will need to be set again after conversion. 

 
Techniques Set the default document language. 

1. From the menubar, select File > Document Properties > 
Advanced tab > Reading Options > Language 

2. Select English US from the dropdown list. 
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3. Select OK. 

Set the language for portions of the text that use a different 
language from the document's default language. 

1. Open the Tags tab by selecting Navigation Tabs > Tags from 
the menubar. 

2. In the Tags tab, expand the tag tree as needed to see the 
elements. 

3. Select the appropriate text element, and choose Properties 
from the Options menu. 
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4. In the TouchUp Properties dialog box, select the Tag tab. 
5. Select a language from the Language dropdown list menu. 

 
6. Select Close. 

Note: The language specified for an element also applies to all 
elements nested under it in the logical structure tree. 
(See Editing the Structure of Tagged Adobe PDF Documents and 
Advanced Tools for Correcting Tagging Errors in the Complete 
Acrobat Help file (F1) for more detailed instructions.) 
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Identify and Correct Reading Order Problems 

 
Test To determine if a document has a logical read order, it will be 

necessary to listen to it using a screen reader, outputing it to an 
alternate file format, viewing it with the TouchUp Reading Order tool, 
and/or reflowing it. 

 
Techniques Check read order using any or all of the following techniques: 

• Listen to the document using a screen reader. 
• Output the document to a text file and read it. 
• Reflow the document. 
• View the document using the TouchUp Reading Order tool. 
Repair read order problems using the Tags tab or the TouchUp 
Reading Order tool. 
(See Editing the Structure of Tagged Adobe PDF Documents and 
Advanced Tools for Correcting Tagging Errors in the Complete 
Acrobat Help file (F1) for more detailed instructions.) 
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Add Elements to the Tag Tree 

 
Test Determine if there are element in the document which are not 

represented within the logical structure tree. 

 
Techniques Add elements to the tag tree using the Tags tab or the TouchUp 

Reading Order tool. 
(See Editing the Structure of Tagged Adobe PDF Documents and 
Advanced Tools for Correcting Tagging Errors in the Complete 
Acrobat Help file (F1) for more detailed instructions.) 
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Set the Tab Order of Pages 

 
Test Listen to the document using a screen reader to determine if the 

document content is read in an order that makes sense. 

 
Note The tab order often, but not always, passes through from the Word 

document. Explicitly setting the default tab order of all pages ensures 
that the tab order of pages is in a logical order. 

 
Techniques Set the tab order of all pages. 

1. Open the Pages tab by selecting Navigation Tabs > Pages 
from the menubar. 

2. In the Pages tab, select all pages 
3. Select Options > Page Properties > Tab Order tab. 

 
4. Select the radio button for Use Document Structure. 
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Use Reflow to Find Problems 

 
Test Reflow the document. If the tagged PDF document does not reflow 

properly, the content order of the PDF file may contain 
inconsistencies, or the tagging process itself may be the cause. 

 
Techniques Reflow the document:  

View > Reflow. 

 
Repair problems using the Tags tab or the TouchUp Reading Order 
tool. 
(See Editing the Structure of Tagged Adobe PDF Documents and 
Advanced Tools for Correcting Tagging Errors in the Complete 
Acrobat Help file (F1) for more detailed instructions.) 
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Review Alternate Text 

 
Test Ensure that alternate text makes sense within the context of the 

document when using a screen reader. 

 
Techniques Return to the Word document and add alternate text to all elements 

which require it. 
Alternately, to add alternate text within Acrobat: 

1. Choose View > Navigation Tabs > Tags. 
2. Expand the logical structure tree to find and select the 

<Figure> tag element for the image. 
3. Choose Highlight Content from the Options menu on the 

Tags tab to see a highlighted area in the document that 
corresponds to the tag. 

4. Choose Properties from the Options menu on the Tags tab. 

 
5. In the TouchUp Properties dialog box, click the Tag tab. 
6. For Alternate Text, type text that describes the figure. 
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Change Tags to Artifacts 

 
Test Ensure that elements which should not be read aloud by the screen 

reader are not. To hide an element from the screen reader, it should be 
marked as an artifact. 

 
Techniques Return to the Word document and use a carriage return as the 

alternate text for all elements which require it. 
Alternately, to change an element to an artifact within Acrobat: 

1. In the Tags tab, expand the section of the logical structure that 
needs to be changed. 

2. Select an element. 
3. Choose Change Tag to Artifact from the Options menu. 
4. If an empty container tag is left behind, delete it. 
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Correct Character Mappings 

 
Test The Accessibility Full Check is the best indicator of character 

mapping issues.  

 
Techniques Return to the Word document and use only characters which do not 

cause a character mapping error in Acrobat. 
Alternately, treat these elements as images and add alternate text, or 
if the character is decorative (such as a bullet), change it to an 
artifact.  
Keep in mind that "correcting" the problem in this way will affect the 
extractability of text content, which may have repercussions if the 
document needs to be repurposed. 
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Fix Table Tags 

 
Test Review the table tags to determine whether columns, rows, and cells 

have been correctly identified.  

 
Note Tables that lack well-defined borders and rules are often tagged 

incorrectly or contain adjacent page elements. Poorly tagged tables 
can be corrected by selecting and redefining them or by splitting 
combined cells by creating a tag for each cell. 
Tables pose a special challenge for screen readers because they 
present textual or numerical data to be easily referenced visually. 
Content within table cells can be complex and might contain lists, 
paragraphs of text, form fields, or another table. 

 
Techniques To check table elements: 

In the Tags tab, expand the tags root to view a table tag. 
1. Select the table tag <Table> and verify that it contains one of 

the following elements: 
• Table Rows <TR>, each of which contains a Table Header <TH> or 

Table Data <TD> cells. 
• <THead>, <TBody>, and <TFoot> sections, each of which contains 

Table Rows. (The table rows contain <TH> cells, <TD> cells, or 
both.) 

V32.doc Page 52 of 62 1/9/2006 



 
2. Do one or more of the following: 

• If the tag for the table does not contain these elements but rows, 
columns, and cells appear in the table in the document pane, use the 
TouchUp Reading Order tool to select and define the table or 
individual cells.  

• If the table contains rows that span across two or more columns, set 
ColSpan and RowSpan attributes for these rows in the tag structure. 

• Re-create the table in the authoring application, and then convert it 
to a tagged PDF document. 

To set ColSpan and RowSpan attributes: 
1. In the Tags tab, select a <TD> or <TH> element. 
2. Choose Properties from the Options menu. 
3. In the TouchUp Properties dialog box, click the Tags tab, 

and then click Edit Attribute Objects. 
4. Select Attribute Objects, and then click New Item to create a 

new Attribute Object Dictionary. 
5. Expand the new dictionary, select the O Layout attribute, and 

then click Change Item. 
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6. Change the Layout value to Table. 
7. Select the Attribute Object Dictionary, and click New Item. 
8. In the Add Key And Value dialog box, type ColSpan or 

RowSpan in the Key box; enter the number of columns or 
rows spanned in the Value box; choose Integer from the Value 
Type pop-up menu; and click OK. 

9. Close the TouchUp Properties dialog box. 
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Check Hyperlinks 

 
Test Review the all document hyperlinks and determine if links are: 

• accurate, 
• active, and 
• descriptive or their destination. 

 
Techniques Review all links, and effect repairs in the original Word document. 

If there is an issue with a very long link that simply cannot be made 
short enough to fit on a single line, use the following technique to 
make it a single link in Acrobat: 
Open the Advanced Editing toolbar: 
View > Toolbars > Advanced Editing

 
Select the link tool: 

 
Links are highlighted: 

 
Select the link box of the second part of the link and delete it. 
Open the Content tab, find the second part of the desired link text, and 
move the text so that it is below the first part of the link text within the 
same container. 
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Delete the empty container element left behind. 
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Set Initial View Preferences 

 
Test Open the document to determine if the initial view is as desired. 

 
Techniques Set the desired initial view properties. 

Select File > Document Properties > Initial View tab. 
Set the Document Options > Show dropdown list to Bookmarks 
Panel and Page. 
Leave the magnification set to default unless there is a strong reason 
to override the user's preferences. Also, leave the Window and User 
Interface Options unchecked, unless there is a strong reason to 
override the user's preferences. 
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View Using High-Contrast Color Combinations 

 
Test Determine if all text is still readable when the document is viewed 

using each of Acrobat's 4 high contrast color combinations. 

 
Techniques View the document using Acrobat's various high contrast modes. 

Edit > Preferences > Accessibility 
Select various High-contrast color combinations and review the 
document. 

 
The follwing example illustrates why background color should not be 
used with text. When viewed using high-contrast black text on white, 
the heading becomes nearly indistinguishable. 
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Expand Abbreviations 

 
Test When a screen reader is used, determine if the meaning of 

abbreviations is clear. 

 
Techniques To add alternate text for an abbreviated term: 

1. In the Tags tab, locate the abbreviated term by doing one of 
the following: 

• Expand the tag tree as needed to see the elements that contain the 
abbreviation. 

• Use the TouchUp Text tool or the Select tool to select the 
abbreviation in the document, and then choose Find Tag From 
Selection from the Options menu to locate the text in the tag tree. 

2. Select the tag for that element, and choose Properties from the 
Options menu.  
Note: If the abbreviation includes additional text, cut the 
additional text and place it in a new <Span> child tag within 
the same <Span> parent tag. 

3. In the TouchUp Properties dialog box, select the Tag tab. 
4. For Alternate Text, type the unabbreviated version of the 

term. 
5. Click Close. 
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Check Color 

 
Test Is color used to convey information that is not otherwise available? 

When viewed in high contrast mode, can the document still be read 
visually? 

 
Techniques Return to the Word document to correct color problems. 
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Review Structure 

 
Test Determine if structural elements, such as H1, H2, LI, P, TABLE, etc. 

have been used have been used adequately. 

 

 
Techniques Repair rstructure problems using the Tags tab or the TouchUp 

Reading Order tool. 
(See Editing the Structure of Tagged Adobe PDF Documents and 
Advanced Tools for Correcting Tagging Errors in the Complete 
Acrobat Help file (F1) for more detailed instructions.) 
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Step 4: 
Optimizing File Size in Acrobat 

 
Why It's 
Important 

Reducing the size of Adobe PDF files improves their performance—
particularly when they're being accessed on the web. 

 
Techniques Use PDF Optimize to optimize the PDF file: 

1. Download the accessible.optimize file provided at the 
following location: 
[http://www.xxx.xxx/accessible.optimize] 

2. Save the accessible.optimize file to the Acrobat PDF 
Optimizer folder, usually located here: 
C:\Documents and Settings\your PIN\Application 
Data\Adobe\Acrobat\7.0\Preferences\PDF Optimizer 
Note: Use the optimizer file provided until the PDF Optimizer 
interface has been mastered. 

3. Select Advanced > PDF Optimizer from the menubar. 

 
4. The PDF Optimizer dialog opens. 
5. Select accessible from the Preset dropdown list. 

 
6. Select OK. 

Save the file using a new filename. 
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